5
$\begingroup$

I am trying to install Concorde linked with QSOPT following these instructions. Regarding QSOPT, I downloaded files from section Intel MacOS 10.6 (64-Bit). But, as I have Apple M1 chip, it does not work. I think that the problem is in the arm64 architecture in terms of QS, however with other more commercial software for Intel processor, I do not face any issue thanks to Rosetta.

The error I am facing when I run

./configure --host=darwin --with-qsopt=fullpath/QS

is

ld: symbol(s) not found for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [concorde] Error 1

Cross-posted on StackOverflow

$\endgroup$
3
$\begingroup$

Thanks to the support of Bill Cook, it is now available a version of qsopt.a for the M1 Apple Chip on the QSOPT download page. This perfectly worked for me by run

./configure --host=darwin --with-qsopt=fullpath/QS

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.